# Lodestar (consensus client) snapshot

| Fact | Value | Source |
|---|---|---|
| Newest stable release | v1.50.1, published 2026-10-22 (not a draft or pre-release) | https://github.com/ChainSafe/lodestar/releases/tag/v1.50.1 |
| License (SPDX) | Apache-2.0 | https://github.com/ChainSafe/lodestar (repository license metadata, via https://api.github.com/repos/ChainSafe/lodestar) |
| Main language | TypeScript | https://api.github.com/repos/ChainSafe/lodestar (GitHub's "language" field for the repo) |
| Maintainer | ChainSafe (the GitHub organization that owns the repo) | https://github.com/ChainSafe/lodestar |

Release data was read from https://api.github.com/repos/ChainSafe/lodestar/releases/latest on 2026-10-27. It reported `prerelease: false`, `draft: false`, and `published_at` 2026-10-22T17:07:52Z.

I took "ChainSafe maintains it" from the repo's owning organization. I did not check a separate page that states it.

## Notable changes in v1.50.1
Source: https://github.com/ChainSafe/lodestar/releases/tag/v1.50.1

1. The release notes call it a critical update that all users must upgrade to. Hoodi operators must upgrade before epoch 132352. v1.50.0 would still activate Gloas at that epoch, even though the Glamsterdam fork on Hoodi has been unscheduled. The fork is unscheduled in #10461, which also unschedules the 200M gas limit on Hoodi.
2. Node.js runtimes were refreshed (#10459). The notes cite the eMudhra certificate authority compromise as the reason. Docker images and binaries now ship Node.js 24.22.1 or newer. The minimum supported Node.js version is now 24.22.1.
3. Users building from source must upgrade Node.js to 24.22.1 or a newer 24.x release. The notes say upgrading Lodestar alone does not fix the issue, because the runtime does.
